Unable to view domain logs in Plesk: TypeError: Cannot read property 'escapeHTML' of null

Created:

2017-04-27 06:49:57 UTC

Modified:

2017-08-16 16:44:46 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to view domain logs in Plesk: TypeError: Cannot read property 'escapeHTML' of null

Applicable to:

  • Plesk for Linux

Symptoms

Unable to view domain logs within Plesk, the following error appears:

TypeError: Cannot read property 'escapeHTML' of null

Plesk log contains the following error:

require.js?1489742387:19 TypeError: Cannot read property 'escapeHTML' of null 
at klass.<anonymous> (https://203.0.113.2:8443/javascript/app/log-browser/browser.js?17.5.3:277:49)
at klass.<anonymous> (https://203.0.113.2:8443/javascript/jsw.min.js?1489742387:2:22693)
at Array.forEach (native)
at klass._getRowHtml (https://203.0.113.2:8443/javascript/jsw.min.js?1489742387:2:22531)
at klass.<anonymous> (https://203.0.113.2:8443/javascript/jsw.min.js?1489742387:2:22210)
at Array.map (native)
at Array.collect (https://203.0.113.2:8443/javascript/prototype.js?1489742387:1270:23)
at klass._getListDataHtml (https://203.0.113.2:8443/javascript/jsw.min.js?1489742387:2:22182)
at klass.listView (https://203.0.113.2:8443/javascript/jsw.min.js?1489742387:2:23132)
at klass.<anonymous> (https://203.0.113.2:8443/javascript/prototype.js?1489742387:120:50)
check @ require.js?1489742387:19
(anonymous) @ require.js?1489742387:23
(anonymous) @ require.js?1489742387:8
(anonymous) @ require.js?1489742387:24
x @ require.js?1489742387:7
emit @ require.js?1489742387:24
check @ require.js?1489742387:20
(anonymous) @ require.js?1489742387:23
(anonymous) @ require.js?1489742387:8
(anonymous) @ require.js?1489742387:24
x @ require.js?1489742387:7
emit @ require.js?1489742387:24
check @ require.js?1489742387:20
enable @ require.js?1489742387:24
init @ require.js?1489742387:17
J @ require.js?1489742387:14
completeLoad @ require.js?1489742387:29
onScriptLoad @ require.js?1489742387:30

Cause

This is Plesk bug with ID #PPPM-6134 which is planned to be fixed in future Plesk updates.

Resolution

Replace file /usr/local/psa/admin/plib/LogBrowser/Parser.php with the attached one.

Attachments:

Have more questions? Submit a request
Please sign in to leave a comment.