Subdomains' SSL certificates are lost after adding certificate to main domain

Created:

2017-04-11 19:12:04 UTC

Modified:

2017-08-16 16:49:09 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Subdomains' SSL certificates are lost after adding certificate to main domain

Applicable to:

  • Plesk for Linux
  • Subdomains' SSL certificates are lost after adding a first certificate to the main domain (they are installed on subdomains before installing some certificate for the main domain)
  • Values cert_rep_id in psa.domains are different for domain and its subdomains:
    mysql> select name, cert_rep_id from domains where name like '%example.com';
    +------------------+-------------+
    | name             | cert_rep_id |
    +------------------+-------------+
    | example.com      |           2 |
    | sub.example.com  |          18 |
    +------------------+-------------+
    2 rows in set (0.00 sec)
  • Unable to see the subdomains' certificates at Domains > example.com > SSL certificates
  • When create a domain first, then create a subdomain, both have different certificate-repository.

Cause

It is caused by internal software issue with id #PPPM-6085 which will be fixed in future updates.

Resolution

As a workaround update certificates' ID manually in Plesk database:

mysql> select name, cert_rep_id from domains where name like '%example.com';
+------------------+-------------+
| name             | cert_rep_id |
+------------------+-------------+
| example.com      |           2 |
| sub.example.com  |          18 |
+------------------+-------------+
2 rows in set (0.00 sec)
mysql> update domains set cert_rep_id=2 where name='sub.example.com';
Query OK, 1 row affected (0.00 sec)
Rows matched: 1 Changed: 1 Warnings: 0
Have more questions? Submit a request
Please sign in to leave a comment.