Note: This article has the reference to the issue with the fix available:
-
#PPPM-6041
"After the latest Kaspersky virus database update, mail was no longer being scanned for viruses, and mail notifications were sent for every unprocessed email."
Fixed in:- Plesk Onyx 17.0.17 Update 22 08 April 2017 (Linux)
Please consider updating your server:
Symptoms
-
After the recent update of Kaspersky's virus database it does not scan incoming email.
-
Plesk administrator receives mail notification with the following content:
Dear User, A message with the following attributes cannot be scanned for viruses due an error: Sender = j.doe@example.com (may be forged)
Recipients = info@domain.tld
Subject = [#115869]: Error
Message-ID = <a99f5990db88a0fa8a8dab15044d062b@support.example.com> -
The following can be found in
/var/log/maillog
:kav-handler[20325]: Evt: 1, p1= 2147746397, p2 = 0, obj = Memory region 1, virus = (null)
kav-handler[20325]: Evt: 32, p1= 4, p2 = 0, obj = Memory region 1, virus = (null)
kav-handler[20325]: Message from j.doe@example.com is non scanned
Cause
Bug PPPM-6041 - Incorrect Kaspersky license key has been retrieved during the Daily Task.
Resolution
Go to: Tools and Settings > License Management > Additional License Keys > KAV.XXXXXXXX.XXXX > Retrieve Additional Key
OR
Via command line:
#
plesk php /usr/local/psa/admin/plib/scripts/kav-key-upgrade.php
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