Applicable to:
- Plesk Onyx for Linux
Symptoms
-
DMARC checks fails with the following error in
/var/log/maillog
:CONFIG_TEXT: Sep 27 13:26:43 server dmarc[24700]: Starting the dmarc filter...
Sep 27 13:26:43 server dmarc[24700]: DMARC store policy from domain failed
Sep 27 13:26:43 server dmarc[24700]: Unable to store SPF/DKIM results into DMARC library
Sep 27 13:26:43 server postfix-local[24697]: Error during 'dmarc' handler -
Emails are not deleted from the directory
/opt/psa/handler/spool/
Cause
Product issue:
-
#PPPM-7166 "DMARC checks no longer result in a segmentation fault under specific circumstances, which caused errors to be written to the logs and temporary files not being cleaned up."
Fixed in:- Plesk Obsidian 21 January 2020 (Linux)
- Plesk Onyx 17.8 10 December 2018 (Linux)
- Plesk Obsidian 31 July 2018 (fixed as PPP-32807, Linux)
Resolution
Workaround
As a workaround apply a custom fix.
Note: the further instructions are intended for server administrators with direct SSH access to the server.
If direct RDP access to the server is not possible, contact server administrator for further assistance.
-
Connect to a Plesk server via SSH.
-
Download the archive:
# wget --directory-prefix=/root http://support.plesk.com/hc/article_attachments/115002980914/ub16_p175_dmarc.tar.gz
-
Backup the original file
/usr/local/psa/handlers/hooks/dmarc
:# cp /usr/local/psa/handlers/hooks/dmarc{,.orig}
-
Unpack the archive:
# tar -zxvf ub16_p175_dmarc.tar.gz
-
Make the file executable:
# chmod 750 /root/dmarc
# chown root.popuser /root/dmarc -
Replace the file
/usr/local/psa/handlers/hooks/dmarc
with the file from the archive:# mv /root/dmarc /usr/local/psa/handlers/hooks/
-
Connect to a Plesk server via SSH.
-
Download the archive:
# wget --directory-prefix=/root https://support.plesk.com/hc/en-us/article_attachments/360006611434/COS7_p178_dmarc.tar.gz
-
Backup the original file
/usr/local/psa/handlers/hooks/dmarc
:# cp /usr/local/psa/handlers/hooks/dmarc{,.orig}
-
Unpack the archive:
# tar -zxvf COS7_p178_dmarc.tar.gz
-
Make the file executable:
# chmod 750 /root/dmarc
# chown root.popuser /root/dmarc -
Replace the file
/usr/local/psa/handlers/hooks/dmarc
with the file from the archive:# mv /root/dmarc /usr/local/psa/handlers/hooks/
-
Connect to a Plesk server via SSH.
-
Download the archive:
# wget --directory-prefix=/root https://support.plesk.com/hc/en-us/article_attachments/360009324593/dmarc-plesk-17.8.11-cos6x64.tar.gz
-
Backup the original file
/usr/local/psa/handlers/hooks/dmarc
:# cp /usr/local/psa/handlers/hooks/dmarc{,.orig}
-
Unpack the archive:
# tar -zxvf dmarc-plesk-17.8.11-cos6x64.tar.gz
-
Make the file executable:
# chmod 750 /root/dmarc
# chown root.popuser /root/dmarc -
Replace the file
/usr/local/psa/handlers/hooks/dmarc
with the file from the archive:# mv /root/dmarc /usr/local/psa/handlers/hooks/
Comments
6 comments
Solution for debian 9.6 ?
Hi @Ahmet Emre Düzgün,
There is no hotfix for Debian 9, however the bug should be fixed in 2-3 weeks according to my information.
Still ocurring on 18.0.24
Hello Chris McBride
In case the provided custom fixes also don't help, additional investigation is required.
Consider submitting a support request to Plesk directly or to a reseller, depending on where the license was purchased.
The fix does solve the issue, but after upgrading to 18.0.24, the issue reoccurred, requiring me to re-apply the fix.
@Chris McBride
It is difficult to tell for sure what happened after upgrade without checking the server logs. Please contact the support for a thorough investigation.
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