Multi Server: unable to access Nodes or Tasks menu: General error: 5 database is locked

Created:

2017-04-04 07:34:01 UTC

Modified:

2017-08-08 13:28:50 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Multi Server: unable to access Nodes or Tasks menu: General error: 5 database is locked

Applicable to:

  • Plesk Onyx for Linux
  • Plesk Multi Server

Symptoms

  • Unable to access Nodes or Tasks menus or a setting with the node selection at Tools & Settings (for example, Scheduled Tasks ):

    Internal error: SQLSTATE[HY000]: General error: 5 database is locked
    Message SQLSTATE[HY000]: General error: 5 database is locked
    File Pdo.php
    Line 61
  • Unable to launch /usr/local/psa/admin/bin/php -dauto_prepend_file=sdk.php '/usr/local/psa/admin/plib/modules/plesk-multi-server/scripts/task-health-checker.php script with the same error

Cause

It is a result of several bugs in Plesk Multi Server. They are planned to be fixed in the future releases.

Resolution

Until the issue is fixed, the following workaround could be applied:

Increase timeout for the Plesk Multi Server internal database in the /usr/local/psa/admin/conf/panel.ini file by setting the busy_timeout parameter (in milliseconds) in the [ext-plesk-multi-server] section:

# vi /usr/local/psa/admin/conf/panel.ini
...
[ext-plesk-multi-server]
db.busy_timeout = 180000
db.profile_log = off

If the issue persists, increase db.busy_timeout parameter:

# vi /usr/local/psa/admin/conf/panel.ini
...

[ext-plesk-multi-server]
db.busy_timeout = 600000
Have more questions? Submit a request
Please sign in to leave a comment.