Applicable to:
- Plesk Onyx 17.5 for Windows
Symptoms
Unable to login to Plesk: no errors appear, the page just loading endlessly.
The following error may appear in a browser while waiting for a page to load:
CONFIG_TEXT: ERR_CONNECTIONS_RESET
Cause
This is Plesk bug with ID PPPM-7137 which is planned to be fixed in future product updates.
Resolution
As a workaround:
- Connect to the server using RDP .
- Open Plesk Services Monitor and press Stop Plesk website :
- In Task Manager terminate all the
php-cgi.exe
processes owned bypsaadm
user, because they can lockphp_lock_manager.dll
file - Download the custom fix attached and unpack it.
- Replace
%plesk_dir%\admin\engine\php_lock_manager.dll
with extracted custom fix file. - Open Plesk Services Monitor and press Start Plesk website
If the patched php_lock_manager.dll does not fix the issue, it is possible to disable lock_manager in Plesk php.ini file:
- Connect to the server using RDP.
- Browse to "%plesk_dir%\admin\conf\" directory and open php.ini with preferable text editor
- Comment the following lines by adding a semicolon at the beginning of the line:
CONFIG_TEXT: ;[php_lock_manager]
;extension=php_lock_manager.dll - If the issue still persists, restart IIS in CMD:
C:> iisreset
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