Applicable to:
- Plesk Onyx for Linux
Symptoms
-
IMAP connection to a Plesk server using MS Outlook does not work after Debian dist-upgrade:
PLESK_ERROR: The connection to the server has failed. Account: ‘your_account’, Server:’your_SMTP_server’, Protocol: SMTP, Port: 25, Secure (SSL): NO, Socket error: 10061, Error Number: 0x800ccc0e
-
The following error can be found in the file
/var/log/syslog:
CONFIG_TEXT: plesk.example.com dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip= 203.0.113.2 , lip= 203.0.113.3 , TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown: SSL alert number 46, session=<sKc5E7VZXlVtWyft>
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SSH connection or access to Plesk administrative panel is temporarily blocked.
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Fail2Ban is enabled and IP address of your workstation can be found in
/var/log/fail2ban.log
:CONFIG_TEXT: fail2ban.filter [2202]: INFO [plesk-dovecot] Found 203.0.113.2
fail2ban.filter [2202]: INFO [plesk-dovecot] Found 203.0.113.2
fail2ban.filter [2202]: INFO [plesk-dovecot] Found 203.0.113.2
fail2ban.filter [2202]: INFO [plesk-dovecot] Found 203.0.113.2
fail2ban.actions [2202]: NOTICE [plesk-dovecot] Ban 203.0.113.2
fail2ban.filter [2202]: INFO [recidive] Found 203.0.113.2
fail2ban.filter [2202]: INFO [plesk-postfix] Found 203.0.113.2
fail2ban.filter [2202]: INFO [plesk-postfix] Found 203.0.113.2
fail2ban.actions [2202]: NOTICE [plesk-postfix] Ban 203.0.113.2
fail2ban.filter [2202]: INFO [recidive] Found 203.0.113.2
Cause
Fail2ban is blocking connections to the server.
Resolution
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Go to Tools & Settings > Mail Server Settings.
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Check what is specified in the field Installed IMAP/POP3 server: Dovecot or Courier-IMAP.
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Go to Tools & Settings > IP Address Banning (Fail2Ban) > Jails.
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Click on plesk-dovecot or plesk-courierimap, depending on the used IMAP/POP3 server found in step 3.
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Click Change Settings.
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Adjust the parameters IP address ban period and The maximum number of failed login attempts: increase the number of failed attempts and/or the ban period.
Also, if the customer affected by the issue uses the permanent IP address, consider adding it to Trusted IP Addresses in Tools & Settings > IP Address Banning (Fail2Ban).
Comments
2 comments
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Hi @David, thank you for sharing!
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