Web Presence Builder Editor does not work: Please wait. Step 1 of 3: Loading libraries...

Created:

2017-03-14 23:31:00 UTC

Modified:

2017-08-08 13:28:28 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Web Presence Builder Editor does not work: Please wait. Step 1 of 3: Loading libraries...

Applicable to:

  • Plesk for Windows
  • Plesk for Linux
  • Plesk Sitebuilder

Symptoms

After upgrade of Web Presence Builder (WPB) to version 11.5, 12.0 or 12.5 WPB does not work correctly:

  1. The following message is shown or stuck when attempting to open a site in WPB:

    Table 'site' - SQLSTATE[42S22]: Column not found: 1054 Unknown column 'is_changed_since_last_publication' in 'field list'
    

    or

    Internal error: Undefined property "logoName"
    

    or

    An internal Presence Builder error has occurred.
    Your website could not be upgraded. You can contact your hosting provider for assistance or start over and create a new site from scratch. If you choose to start over, all your website content will be lost.
    

    or

    Please wait. Step 1 of 3: Loading libraries...
    
  2. The following error is shown in /usr/local/psa/admin/logs/sitebuilder.log :

    SB_Exception: Site version are not latest
    

    or

    SB_Upgrade_Exception: The database upgrade is not completed.
  3. A database sitebuilder5 was not properly upgraded:

        # rpm -q pp-sitebuilder
    pp-sitebuilder-11.5.7-41714.13100419.noarch
      # mysql -u%mysql_user% -p%mysql_password% sitebuilder5 -e"select * from config_param where name='version'"
    +----+-------------------+---------+---------+-----------+
    | id | config_section_id | name | value | in_backup |
    +----+-------------------+---------+---------+-----------+
    | 1 | 1 | version | 11.0.10 | 0 |
    +----+-------------------+---------+---------+-----------+

    The database upgrade log is stored in /usr/local/sb/tmp/upgrade.log . The following error may be found in the log (for example):

        [EMERG]         Zend_Db_Statement_Exception: Table 'site_template' - SQLSTATE[23000]: Integrity constraint violation: 1062 
        Duplicate entry 'construction_company_new_m4jy1i0' for key 'code'

    Cause

    Database of Web Presence Builder was not upgraded to version 11.5/12.0/12.5

    Resolution

    1. Dump the existing WPB database:

      # mysqldump -u%mysql_user% -p%mysql_password% --skip-extended-insert sitebuilder5 > sitebuilder5.dump.`date +%F.%s`.sql
      
    2. Delete the problem record (shown in the upgrade log):

      mysql> delete from sitebuilder5.site_template where code='construction_company_new_m4jy1i0';
      
    3. Reinstall the base package of Web Presence Builder 11.5:

      # wget http://autoinstall.plesk.com/SITEBUILDER_11.5.7/dist-rpm-RedHat-all-all/base/pp-sitebuilder-11.5.7-41714.13100419.noarch.rpm
       rpm -Uvh pp-sitebuilder-11.5.7-41714.13100419.noarch.rpm  --force
      
    4. For Web Presence Builder 12.0, reinstall the base package using:

      # wget http://autoinstall.plesk.com/SITEBUILDER_12.0.5/dist-rpm-RedHat-all-all/base/wpb-core-12.0.5-43480.14051315.noarch.rpm
       rpm -Uvh wpb-core-12.0.5-43480.14051315.noarch.rpm --force

    If the previous solution did not help:

    • Run the following command to restart the upgrade process in Plesk for Linux:

      ~# /usr/local/psa/bin/sw-engine-pleskrun /usr/local/sb/utils/upgrade.php
      ~# /usr/local/psa/bin/sw-engine-pleskrun /usr/local/sb/utils/post_configure.php
      ~# /usr/local/psa/admin/sbin/autoinstaller --select-release-current --reinstall-patch --install-component base
      
    • In Plesk for Windows:

      > %plesk_bin%\php.exe -d auto_prepend_file="" "%plesk_dir%\sb\utils\post_configure.php"
      > %plesk_bin%\php.exe -d auto_prepend_file="" "%plesk_dir%\admin\plib\scripts\upgrade-complete.php"
      > %plesk_bin%\ai.exe --select-product-id panel --select-release-current --reinstall-patch --install-component base
      

      Where %plesk_bin% and %plesk_dir% are pathes for Plesk installation directories.

    • For Web Presence Builder Standalone:

      ~# /usr/bin/sw-engine /usr/local/sb/utils/upgrade.php
      ~# /usr/bin/sw-engine /usr/local/sb/utils/post_configure.php
Have more questions? Submit a request
Please sign in to leave a comment.