Applicable to:
- Plesk Onyx 17.5 for Windows
Symptoms
-
After installing Plesk updates, it is not possible to access Plesk.
-
The following error is shown instead of login screen:
CONFIG_TEXT: ERROR: Exception: Unable to get administrator password: The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\.\pipe\P_4755d610-937d-498b-a70f-6ee61941f472
at (Con::ClientOverlappedPipe::create line 503)
at getPassword('pwd')(PleskSrvClient::getPassword line 218)
at (zif_get_admin_password line 277) (Helper.php:68) -
The following errors can be found in the
C:\ParallelsInstaller\autoinstaller3.log
:CONFIG_TEXT: MSI: Error! Error writing to file: C:\Program Files (x86)\Parallels\Plesk\admin\bin\reconfigurator.exe. Verify that you have access to that directory.
MSI (01): Error writing to file: C:\Program Files (x86)\Parallels\Plesk\admin\bin\reconfigurator.exe. Verify that you have access to that directory.
Failed to install 'C:\ParallelsInstaller\parallels\PANEL-WIN_17.5.3\dist-msi-Microsoft-2003-i386\plesk-service-node-utilities_mu021.msi': Fatal error during installation. (Error code 1603)
Action '<install-msi-package command-line="REINSTALL=ALL REINSTALLMODE=vmscd ADDLOCAL=ALL ALLUSERS=1 ARPSYSTEMCOMPONENT=1 REBOOT=R AUTOINSTALLER=1" />' failed with error 1603(0x00000643)
Error: The installation of the package 'plesk-service-node-utilities' failed with code 1603. (upgrade: Upgrading Plesk Utilities...)
Not all packages were installed.
Please contact product technical support.
Cause
Failed update of Plesk Utilities (plesk-service-node-utilities
) package.
Resolution
-
Connect to the server using RDP .
-
Open Command Prompt and launch Plesk Installer in the interactive console mode:
C:\> plesk installer --console
If Plesk command is not working, then run installer directly over the file:
C:\> "%plesk_bin%\ai.exe" --console
-
On the Main components list for Plesk screen make sure that Base packages of Plesk component is marked for update (with "*" sign) and proceed with the update.
Comments
5 comments
What should be done if star does not appear? I followed the same instructions as well. Please let me know if anything else needs to be added. Thanks.
I tried this and I don't get a [*] for the Base packages of Plesk option. It has [=]
What is the alternative?
1. You may try to repair Plesk services:
Plesk Reconfigurator > Repair Plesk Installation > Plesk Services .
2. After that make sure that "Plesk Management Service" is started under Windows Services.
I tried the repair process also and now i am getting different error.
Here is the steps :
Hello Mohan Raj,
The cause of the error is not clear at the moment.
Please contact Plesk technical support directly for assistance and troubleshooting:
https://support.plesk.com/hc/en-us/requests/new
Please sign in to leave a comment.