Unable to upload a backup via FTPS: Unable to save data to an archive

Created:

2017-03-14 17:33:12 UTC

Modified:

2017-08-16 16:28:39 UTC

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Unable to upload a backup via FTPS: Unable to save data to an archive

Applicable to:

  • Plesk Onyx for Linux

Note: This article has the reference to the issue with the fix available:

  • #PPPM-5922 "Backups could not be uploaded to an FTP repository via the FTPS protocol."
    Fixed in:
Please consider updating your server:

Symptoms

  • Unable to upload a backup via FTPS. Only corrupted .tar of several KB size is uploaded.
  • Errors in /usr/local/psa/PMM/sessions/session_name/migration.log :
    INFO: * Uploaded unaligned file size (16384 out of 0 bytes) 
    INFO: * Connection #1 to host example.com left intact
    INFO: Data sending interrupted, because of lost connection to FTP
    INFO: Unable to save data to an archive

Cause

This is Plesk bug with ID #PPPM-5922 which ihas been fixed in Plesk Onyx MU #21.

Resolution

Install the latest micro-update with the following command:

# plesk installer --select-release-current --reinstall-patch --upgrade-installed-components

In case installing micro-updates is not an option use the hotfix as described below:

  1. Back up pmm-ras file:
    # cp /opt/psa/admin/sbin/pmm-ras /opt/psa/admin/sbin/pmm-ras.back
  2. Download the fix for the Ubuntu 14 or for the Ubuntu 12 and unpack it to /opt/psa/admin/sbin/pmm-ras .

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