Plesk for Windows
Plesk for Linux
kb: technical
ABT: Group B
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
- Unable to open the Plesk > Tools & Settings > Updates & Upgrades (Updates) page, with the error below:
CONFIG_TEXT: This site can’t be reached
ERR_CONNECTION_TIMED_OUT - The Updates & Upgrades (Updates) page successfully opens via
https://203.0.113.2:8447
link( where203.0.113
is the server IP address). - Using the DNS Checker utility it can be found that the DNS of the server hostname is hosted on the Cloudflare side:
Cause
The Cloudflare does not support proxy over 8447 port.
Resolution
Solution I
1. Log into Plesk using the server IP address instead of the server hostname, the link should be as shown below:
CONFIG_TEXT: https://203.0.113.2:8443
2. Go to Tools & Settings > Updates & Upgrades (Updates) page.
Solution II
Directly access Updates & Upgrades (Updates) via Internet browser using the link below:
CONFIG_TEXT: https://203.0.113.2:8447
Comments
8 comments
Hi,
Did anyone find a solution/workaround for CF? To me, they said I need an Enterprise account in order to access 8447.
Thanks
Hi @Mario,
As a workaround, open Plesk Installer on port 8447 by specifying the server IP address:
https://203.0.113.2:8447
Thanks,
I was getting an "ERR_CONNECTION_TIMED_OUT" error there too. However, I found a workaround on one of your KB's:
1) Access port 8443 by IP (https://server_IP:8443)
2) Navigate to "HOME > Tools & Settings > Updates and Upgrades "
Hope it helps others.
Hello @Mario !
Thank for sharing the information.
Neither of the solutions works for me. Thinking about ditching Cloudflare.
Chris McGee what error do u get when accessing via both options?
You can also access via command line in windows or via ssh in linux with 'plesk installer' command.
I don't know if something has changed within the last month, but I just tried Mario's posted solution and I can now access that "Updates" area of Plesk.
Attempting to reach the site via IP:8447 still gives me an "ERR_CONNECTION_RESET" error. But since I can reach it via the Plesk GUI, then I'm okay for now.
We do need a solution from Plesk to remove the 8447 port on the "Tools & Settings - Updates" feature.
We can do this with the 8443 using the "Tools & Settings > Customize Plesk URL".
By we can't do the same with the "Tools & Settings - Updates"?
The point here it's to be able to use Plesk without ports to make works with Cloudflare Proxy.
Also, without ports, we can add Cloudflare Access for 2FA which is perfect to increase security.
We should be able to use everything from the Plesk Admin without the 8443 & 8447 ports.
This is a very simple request and not sure why Plesk can't offer a solution for this.
Exposing login pages are not safe.
Any solution from Plesk for this?
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