Applicable to:
- Plesk for Linux
Symptoms
-
MySQL has been upgraded and now fails to start.
-
The following error message appears in
/var/log/mysqld.log
when trying to start MySQL:CONFIG_TEXT: [ERROR] Fatal error: mysql.user table is damaged. Please run mysql_upgrade.
-
Plesk is not accessible with the following error message in a browser:
PLESK_INFO: ERROR: Zend_Db_Adapter_Exception: SQLSTATE[HY000] [2002] No such file or directory
Additionally, an exception has occurred while trying to report this error: Zend_Exception
No entry is registered for key 'translate' (Abstract.php:144)
Cause
MySQL 5.1 has been upgraded to 5.5 without running the "mysql_upgrade" command.
Resolution
-
Connect to the Plesk server via SSH.
-
Add the "skip-grant-tables" record to log in to MySQL:
2.1. Open MySQL configuration file
/etc/my.cnf
in a text editor. In this example we use the vi editor:# vi /etc/my.cnf
2.2. Add "skip-grant-tables" on a new line under the [mysqld] section:
CONFIG_TEXT: [mysqld]
skip-grant-tables
<...>2.3. Save the changes and close the file.
-
Start MySQL:
# service mysqld start
OR
# service mysql start
-
Complete the MySQL upgrade:
# mysql_upgrade
-
Remove the line with "skip-grant-tables" from the
/etc/my.cnf
file. -
Restart the MySQL service using one of these commands:
# service mysqld restart
# service mysql start
Comments
4 comments
Hi, sorry for starting a new question here, but I have moved my hosting from 123-reg to ionis and I cannot find the licence key in the location you say it should be in.
Now despite being told the reason my site was not showing videos was because the database was outdated, I still have the same issue. If you go to my home page, you will see there are no videos on show anywhere and also the menu is all odd. Any ideas please?
Using putty it does not allow me to save normally like CTL X. so its caused major issues now!
Mark White is this related to any issue you are experiencing with the article? Please open a support ticket with us if you need assistance: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
Hello Mark White,
As the key info isn't displayed for you there's a possibility that you aren't logged in as Plesk administrator.
Please, contact a company where hosting was purchased for support.
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