Unable to install package from hardware node: psa-mail-driver-common conflicts with plesk-core

Created:

2017-03-03 12:28:12 UTC

Modified:

2017-08-08 13:43:04 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install package from hardware node: psa-mail-driver-common conflicts with plesk-core

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Unable to install package, for example, pp-postfix from hardware node. Installation fails with:

--> Running transaction check 
---> Package libbsd.x86_64 0:0.6.0-1.el6 will be installed
--> Processing Conflict: psa-mail-driver-common-17.0.17-cos6.build1700170131.16.x86_64 conflicts plesk-core < 12.0.6
--> Finished Dependency Resolution
Error: psa-mail-driver-common conflicts with plesk-core You could try using --skip-broken to work around the problem
** Found 26 pre-existing rpmdb problem(s), 'yum check' output follows:
libaps-1.0.8-centos6.798670.16071418.x86_64 is a duplicate with libaps-1.0.6-798670.13080109.x86_64
php5-ioncube-loader-5.0.18-centos6.16102516.x86_64 is a duplicate with php5-ioncube-loader-4.2.2-13031415.x86_64
plesk-base-17.0.17-cos6.build1700161028.14.x86_64 has installed conflicts psa < ('0', '12.1.11', None): psa-11.5.30-cos6.build115130819.13.x86_64
plesk-base-17.0.17-cos6.build1700161028.14.x86_64 is a duplicate with plesk-base-11.5.30-cos6.build115130819.13.x86_64
plesk-completion-17.0.17-cos6.build1700161028.14.noarch is a duplicate with plesk-completion-11.5.30-cos6.build115130819.13.noarch
plesk-core-17.0.17-cos6.build1700161028.14.x86_64 is a duplicate with plesk-core-11.5.30-cos6.build115130819.13.x86_64

Cause

Plesk container has duplicate packages.

Resolution

  1. Install yum-utils package inside Plesk container:

    # yum install yum-utils
  2. Check for duplicated packages with the command:

    # package-cleanup --dupes
    Loaded plugins: fastestmirror
    ...
    plesk-core-11.5.30-cos6.build1200140606.15.x86_64
    plesk-core-17.0.17-cos6.build1700161028.14.x86_64
    ...
  3. Make sure that there is no important package can be removed. Try to clean out the older versions of packages:

    # package-cleanup --cleandupes
  4. Try to install package again.

Have more questions? Submit a request
Please sign in to leave a comment.