- Plesk Onyx
- The error occurs during Bundle Install for domain:
PLESK_ERROR: the running version of Bundler (1.13.5) is older than the version that created the lockfile (1.15.3). We suggest you upgrade to the latest version of Bundler by running gem install bundler .
Fetching gem metadata from https://rubygems.org/.........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
- Following entries in
CONFIG_TEXT: An error occurred while installing nio4r (2.1.0), and Bundler cannot continue.
Make sure that `gem install nio4r -v '2.1.0'` succeeds before bundling. /var/www/vhosts/example.com/httpdocs/vendor/bundle/ruby/2.4.0/extensions/x86_64-linux/2.4.0-static/nio4r-2.1.0/mkmf.log
ERR [panel] Task failed: id=292, pid=1531, type=ext-ruby-task\bundleinstall, error=Warning: the running version of Bundler (1.13.5) is older than the version that created the lockfile (1.15.3). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.
Gem files will remain installed in /var/www/vhosts/example.com/httpdocs/vendor/bundle/ruby/2.4.0/gems/nio4r-2.1.0
Results logged to
Lack of instruments for installing Bundler.
Apply following solutions:
- Login into Plesk.
- Go to Tools & Settings > Updates and Upgrades > Add/Remove Components > Web hosting and make sure that next components are installed:
- Phusion Passenger server
- Ruby support
- Tools required for building Ruby gems
In case the issue persists:
- Change the Application Mode to development in Domains > example.com > Ruby:
- Change Ruby Version in Domains > example.com > Ruby: