Applicable to:
- Plesk for Linux
Symptoms
On a Plesk for Linux server, the log file /var/log/maillog
contains different errors NOQUEUE: reject: RCPT from
:
-
CONFIG_TEXT: plesk.example.com postfix/smtpd[18336]: NOQUEUE: reject: RCPT from unknown[203.0.113.2]: 554 5.7.1 <unknown[203.0.113.2]>: Client host rejected: Access denied; from=<user@domain.com> to=<user@example.com> proto=ESMTP helo=<domain.com>
-
CONFIG_TEXT: plesk.example.com postfix/smtpd[26537]: NOQUEUE: reject: RCPT from some.unknown.domain.com[203.0.113.2]: 454 4.7.1 <info@example.com>: Relay access denied; from=<bot@bounce.mailing.somedomain.com> to=<info@example.com> proto=ESMTP helo=<some.unknown.domain.com>
-
CONFIG_TEXT: plesk.example.com postfix/smtpd[29579]: NOQUEUE: reject: RCPT from unknown[203.0.113.2]: 550 5.1.1 <nouser@example.com>: Recipient address rejected: User unknown in virtual mailbox table; from=<user@example.com> to=<nouser@example.com> proto=ESMTP helo=<SOM-PC>
Cause
- The error
Client host rejected: Access denied
means that a client could not use allowed authentication methods.
Note: it could be caused by a misconfiguration:
https://support.plesk.com/hc/en-us/articles/213364749 - The error
Relay access denied
means that a client tried to use a server as a relay, but the settings are too restrictive.
Note: it could be caused by a misconfiguration. To change relay settings, use the option Tools & Settings > Mail Server Settings > Relay options.
- The error
Recipient address rejected: User unknown in virtual mailbox table
means that somebody tried to send mail to the nonexistent user.
Resolution
Most of the time no actions need to be performed since the mail works the way it is supposed to work.
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