Kernelcare extension license expired, a paid add-on license does not take any affect

Created:

2017-02-21 09:39:59 UTC

Modified:

2017-08-08 13:16:06 UTC

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Kernelcare extension license expired, a paid add-on license does not take any affect

Issue

Plesk extension key has expired, however Plesk+paid add-on license for KernelCare in Tools and Settings > License Management > Additional Licenses is active. In the extension's interface following message exists: 

The following messages may be sent to Plesk administrator:

Mail subject: Cron <root@example> /usr/bin/kcarectl --auto-update
Message: The IP 203.0.113.2 was already used for trialing on 2017-05-16
No handlers could be found for logger "kcare"

The following command results in an output:

# kcarectl --license-info
Your trial license for the IP 203.0.113.2 expired on 2017-05-15

Following error may appear in /usr/local/psa/admin/logs/panel.log:

DEBUG [extension/kernelcare-plesk] [58abc79251960] Starting: '/usr/local/psa/admin/bin/modules/kernelcare-plesk/kcare_plugin_utility.sh' 'plugin-info', stdin:
INFO [panel] Session 51e8fedc51ac87d7ce183ea65496e408 was not saved: not modified DEBUG [extension/kernelcare-plesk] [58abc7934754e] Finished in 0.56546s, Error code: 3, stdout: Key limit reached
DEBUG [extension/kernelcare-plesk] [5937d2b106e27] Finished in 2.39585s, Error code: 0, stdout: --START--
4
Your trial license for the IP 203.0.113.2 expired on 2017-04-30
LICENSE: 0
True
3.10.0-514.21.1.el7.x86_64
3.10.0-514.21.1.el7.x86_64

Cause

Kernel Care key was installed on more than 1 server. KernelCare generates a unique token once the license was first time used for activation. That's why the activation will not work if a license is used on more than 1 server.

Resolution

Contact KernelCare support for assistance

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