Applicable to:
- Plesk for Windows
Note: This article has the reference to the issue with the fix available:
-
#PPPM-5812
"DKIM settings could not be managed if SmarterMail 14.x or earlier was installed on the server."
Fixed in:- Plesk Onyx 17.5.3 23 March 2017 (Windows)
Please consider updating your server:
Symptoms
DKIM support cannot be enabled in Plesk 17.0:
-
Enabling the option
DKIM spam protection
at
Tools & settings > Mail server settings
returns the following error:
sfdk_server_wide_sign_failed
-
Enabling
Use DKIM spam protection system to sign outgoing email messages
at
Domains > example.com > Mail settings
returns the following error:
SOAP ERROR: GenerateDKIMCert(server.example.com, 1024, default) failed: Error code 0x803d0013. Error message: The body of the received message contained a fault. Fault reason: Unable to handle request. The action 'http://tempuri.org/GenerateDKIMCert' was not recognized.
at (WebService::Error::checkResult line 103)
at generateDKIMKeyPair(default, 1024)(SmarterMail::Common::Domain::generateDKIMKeyPair line 208)
at execute console command --generate-domain-dkim-key-pair(vconsoleapp::start line 122)
at execute mailmng.exe --generate-domain-dkim-key-pair "--domain-name=server.example.com
"(vconsoleapp::run line 139)
C:\Program Files (x86)\Parallels\Plesk\admin\bin>mailmng.exe --generate-domain-dkim-key-pair --domain-name=server.example.com
- Corresponding DNS records for DKIM are not created under Domains > example.com > DNS settings .
The error appears during Plesk upgrade to 17.0 version:
Cause
This is Plesk bug with ID #PPPM-5812 which has been fixed in Plesk Onyx 17.5.
Resolution
Upgrade to the latest stable available Plesk version.
As a workaround for Plesk 17.0, upgrade SmarterMail to 15.x version.
Comments
0 comments
Please sign in to leave a comment.