Plesk
kb: technical
ABT: Group B
Applicable to:
- Plesk
Symptoms
- Cannot login into WordPress admin dashboard because the
wp-login.php
file is downloaded instead of opening. -
Opening website leads to the
index.php
being downloaded instead of being opened.
Cause
PHP support is disabled for the example.com
domain at Plesk > Domains > example.com > PHP Settings.
Resolution
Enable the PHP Support for the example.com
website in one of the following ways:
via Plesk Graphical Interface
-
Log into Plesk and navigate to Domains > example.com > PHP Settings.
-
Mark the PHP Support checkbox and press the OK button:
Comments
6 comments
I have the same problem from time to time, its working normally for weeks, and suddenly a php FIle is downloaded instead of showing the website... Restarting Apache normally helps, but its disturbing... could there be another cause? I suspect something cache related. When it happens it happens on several sites, all WordPress.
I've updated to Plesk 18.0.30
i have the same problem with downloading the PHP Files which is really a security risk!!!
PHP was enabled PHP-FastCGI switched to PHP-FPM no success.
Hello Patrick Hofmann
Maybe this happens during high load. There's a possibility that solution from this article would help: https://support.plesk.com/hc/en-us/articles/214528405
Jan Bludau
Try this article: https://support.plesk.com/hc/en-us/articles/115002684014
Patrick and Jan, in case these solutions won't help, submit support requests to Plesk or our partner depending on where the license was purchased.
Well for me the files are empty, so at least its not a securety risk...
I will take a look at the max children settings, it sounds somewhat plausible, espevcially as it is gone after a restart of apache. However i did not see this message in the logfiles.....
Thanks for pointing this out!
I'm having the same issue with one domain we are hosting. It's downloading an empty file with no extension. I've rebooted, change handlers, all components are updated. Is there any solution that works?
Hello Michael Hall I see you already tried all basic things we might suggest, hence please create a request to support to check the issue: https://bit.ly/32irmsk
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