Integration with MSSQL breaks when PCI compliance settings in use

Created:

2017-02-17 06:32:41 UTC

Modified:

2017-08-16 18:29:05 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Integration with MSSQL breaks when PCI compliance settings in use

Applicable to:

  • Plesk Onyx for Windows
  • Plesk Onyx

Note: This article has the reference to the issue with the fix available:

  • #PPPM-5802 "Plesk could not manage Microsoft SQL Server instances that were hardened in accordance with the PCI compliance guidelines."
    Fixed in:
Please consider updating your server:

Symptoms

After applying of PCI compliance settings on the server, integration between Plesk and MSSQL server gets broken. The following error could be found in %plesk_dir%admin/logs/php_error.log :

    [DBNETLIB][ConnectionOpen (SECCreateCredentials()).]SSL Security error.

Cause

Bug with id #PPPM-5802 which is planned to be fixed in future Plesk updates, release notes are available here .

Resolution

As a workaround:

1. Download .zip archive for Plesk Onyx or for Plesk 12.5 .
2. Unarchive it.
3. Back up %plesk_dir%admin\bin\mssqlmng.exe and %plesk_dir%admin\bin\statistics_collector.exe files.
4. Replace the files %plesk_dir%admin\bin\mssqlmng.exe and %plesk_dir%admin\bin\statistics_collector.exe with the ones from the archive.

Attachments:

Have more questions? Submit a request
Please sign in to leave a comment.