Symptoms
Emails on a Plesk for Windows are delivered to external servers with 10 minutes delay.
According to logs in C:\Program Files (x86)\Parallels\Plesk\Mail Servers\Mail Enable\Logging\SMTP SMTP-Activity-***.log
file, messages are delivered successfully:
CONFIG_TEXT: 08/16/17 19:29:12 ME-I0018: [25E4934389A84C6E8538FB0298B6289E.MAI] Outbound message from ([SMTP:user@example.com]) requeued as [911417B7E447475DAE6304B0BAE00EB5.MAI] to the target domain [external.domain]
08/16/17 19:29:12 ME-I0123: Domain [external.domain] has MX list [mail.external.domain]
08/16/17 19:29:12 ME-I0026: [911417B7E447475DAE6304B0BAE00EB5.MAI] Sending message
08/16/17 19:29:12 ME-IXXXX: [911417B7E447475DAE6304B0BAE00EB5.MAI] DNS resolved to the following record: IP Address=203.0.113.2, Family=2, Type=1, Protocol=6
08/16/17 19:29:13 ME-I0049: [911417B7E447475DAE6304B0BAE00EB5.MAI] Send Completed Successfully (0.109s).
Cause
Server time is misconfigured
Resolution
Update the server time by clicking on time bar in the bottom right side of the desktop > Change date and time settings menu
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