Applicable to:
- Plesk Onyx 17.5 for Linux
Symptoms
-
A scheduled server backup task to FTP storage is finished successfully.
-
An hour later, an email notification with the following text is received on the email address specified in Tools & Settings > Backup Manager > Schedule > If errors occur during the execution of this backup task, send a notification email to :
The following error occurred during the scheduled backup process:
Unable to access to the storage: Transport error: unable to list directory: Curl error: (7) Couldn't connect to server: Last FTP request: Last FTP response:
Make sure you have entered the correct storage settings. You can check them independently with the command:
curl -v --ftp-pasv --ssl -k -u user 'ftp://203.0.113.2/folder/' -
The following error can be found in the
/var/log/plesk/PMM/pmmcli.log
file just before the email notification is received:INFO: Executing <subprocess[3041] '/usr/local/psa/admin/bin/pmm-ras --delete-exported-dump --dump-storage=ftps://user@203.0.113.2/folder --dump-file-specification=backup_1234567890.tar --use-ftp-passive-mode --guid=4d60ada4-5e05-483d-837e-661ad4e1999f --session-path=/var/log/plesk/PMM'>
INFO: Subprocess raised ExecuteException: Subprocess <subprocess[3041] '/usr/local/psa/admin/bin/pmm-ras --delete-exported-dump --dump-storage=ftps://user@203.0.113.2/folder --dump-file-specification=backup_1234567890.tar --use-ftp-passive-mode --guid=4d60ada4-5e05-483d-837e-661ad4e1999f --session-path=/var/log/plesk/PMM'> was finished with exit code 125
== STDOUT ====================
== STDERR ====================
DEBUG: <pmmcli.PmmRasExecAction object at 0x2a743d0>: response
INFO: Outgoing packet:
<?xml version="1.0" ?><response>
<errcode>125</errcode>
<errmsg>FTP connection error</errmsg>
<data>
<plain-data/>
</data>
</response> - The following error can be found in the
/var/log/plesk/PMM/pmmcli.log.2017-08-18-143809
file just before the email notification is received:/var/log/plesk/PMM/pmmcli.log.2017-08-18-143809:[2017-08-17 04:06:16.246| 8386] INFO: Curl output: * connect to 192.168.0.1 port 21 failed: Connection timed out
/var/log/plesk/PMM/pmmcli.log.2017-08-18-143809:[2017-08-17 04:06:16.247| 8386] INFO: Curl output: * Failed to connect to 192.168.0.1 port 21: Connection timed out
[2017-08-17 04:08:23.486|8385] INFO: Outgoing packet:
<?xml version="1.0" ?><response>
<errcode>125</errcode>
<errmsg>FTP connection error</errmsg>
<data>
<plain-data/>
</data>
</response>
Cause
Connection rate limit reached on FTP-server side. Plesk needs several connections in a short time to rotate/delete old backups on FTP server.
Resolution
1. Verify that network connection to remote FTP server is stable
2. Adjust connections rate limit to remote FTP-server
Comments
0 comments
Please sign in to leave a comment.