Applicable to:
- Plesk Onyx for Linux
- Plesk Onyx for Windows
Symptoms
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Many subscriptions are in the locked status without any changes from Plesk administrator's side.
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Subscription is getting locked after any changes of PHP settings in Plesk > Subscriptions > example.com > PHP Settings by customer.
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PHP version and handler management is selected in Service Plans > Hosting Plans > Example Plan > Permissions tab.
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Hosting settings management is not enabled at Service Plans > Hosting Plans > Example Plan > Permissions tab.
Cause
Product issues:
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#PPPM-5442 "Changing a subscription’s PHP settings no longer locks the subscription if the “PHP version and handler management” permission is granted to the subscription."
Fixed in:- Plesk Onyx 17.8 25 February 2020
- Plesk Onyx 17.5 25 February 2020
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#PPP-39395 "If the “PHP version and handler management” permission is selected in a service plan, a subscription under this service plan is no longer locked for sync after changing the domain’s PHP version."
Fixed in:- Plesk Obsidian 15 January 2019
Resolution
Workaround
If update is not possible for some reason, apply the following workaround:
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Go to Service Plans > Hosting Plans > Example Plan > Permissions tab.
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Enable the option Hosting settings management.
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Press the Update & Sync button to apply the changes.
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Synchronize subscriptions with its service plans. For more information see:
Comments
2 comments
Hi, I checked not fixed completely, please check my detailed report: https://talk.plesk.com/threads/subscriptions-become-locked-for-sync-if-php-settings-are-changed.355713/
Hello Nethub
Thank you for the message.
The communication will be continued in a forum thread.
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