POP3 client emails are duplicated after migration

Created:

2017-02-07 21:27:48 UTC

Modified:

2017-08-08 13:21:40 UTC

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POP3 client emails are duplicated after migration

Symptoms

After migration POP3 client emails are duplicated in their mail client if POP3 client is configured to keep emails on the server.

Cause

If POP3 client is configured to keep emails on the server and the messages' UIDLs change, all the messages are downloaded again as new messages. Because when migrating emails from another Courier POP3 server, old UIDLs retained in courier specific format. 

This is a bug with ID PMT-3478 which is planned to be fixed in future Plesk updates.

Additional information available here:
http://wiki.dovecot.org/Migration
http://wiki.dovecot.org/Migration/Courier

Resolution

To avoid duplicating emails run the following on target server, but after all migration/re-sync tasks will be finished.


~# /usr/lib64/plesk-9.0/maildir-migrate-dovecot --convert --to-dovecot --recursive --overwrite /var/qmail/mailnames

It is important to run this as a very last step, to avoid cases when emails arrived on the source server and re-synced after the UIDLs conversion was executed.

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