Installation of Plesk updates fails due to unsolvable dependencies

Created:

2017-02-06 20:15:13 UTC

Modified:

2017-08-08 13:14:14 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Installation of Plesk updates fails due to unsolvable dependencies

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Installation of Plesk updates fails with the following errors:

Removing plesk-php56-release.x86_64 0:5.6.29-centos7.16120912 - ud due to obsoletes from installed plesk-service-node-utilities-17.0.17-cos7.build1700161028.14.x86_64
Removing plesk-php56-release.x86_64 0:5.6.30-centos7.17012012 - u due to obsoletes from installed plesk-service-node-utilities-17.0.17-cos7.build1700161028.14.x86_64
PLESK_17_PHP56/filelists_db | 11 kB 00:00
Exception: Failed to solve dependencies:
plesk-php56-release-5.6.29-centos7.16120912.x86_64 requires plesk-php56 = 5.6.29-centos7.16120912

Cause

Mismatch of the plesk-php56-release and plesk-service-node-utilities packages.

Resolution

  1. Remove the plesk-php56-release-5.6.29 package only from RPM database:

    # rpm -e --nodeps --justdb plesk-php56-release-5.6.29
    

    OR

    Remove the plesk-service-node-utilities package only from RPM database:

    # rpm -e --nodeps --justdb plesk-service-node-utilities
    
  2. Continue with installing of Plesk updates:

    # plesk installer --select-release-current --reinstall-patch --upgrade-installed-components
    
Have more questions? Submit a request
Please sign in to leave a comment.