Applicable to:
- Plesk Onyx for Windows
Symptoms
-
After applying SSL certificate for securing webmail under
example.com
domain URLhttp://webmail.example.com
is inaccessible (shows Plesk Default Page) or the error below:CONFIG_TEXT: HTTP Error 500.24 - Internal Server Error
Detailed Error Information:
Module ConfigurationValidationModule
Notification BeginRequest
Handler ExtensionlessUrlHandler-Integrated-4.0
Error Code 0x80070032 -
Webmail can be accessed via HTTPS
-
Port 80 (HTTP binding) is replaced by 443 port (HTTPS binding) in IIS > Sites >MailEnable Webmail > Bindings.
Cause
Product issue:
-
#PPPM-6184 "Removed obsolete information from the notification shown when securing webmail with an SSL/TLS certificate."
Fixed in:- Plesk Obsidian 14 April 2020 (Windows)
Resolution
Workaround
If update is not possible for some reason you may try the following
To add 80 port for one site follow the steps:
-
Log in the server using RDP.
-
Go to Internet Information Services (IIS) Manager > Sites > MailEnable WebMail > Bindings.
Note: For Smartermail or Horde webmail, the next steps have to be done under webmail(smwebmail) or webmail(horde) respectively instead of MailEnable WebMail.
-
Add the corresponding binding record with the webmail.example.com hostname on 80 port.
-
Restart webmail website in IIS > Sites > MailEnable Webmail > Restart.
In addition, HTTP to HTTPS redirect rule for Webmail can be created:
-
Go to IIS > Sites > MailEnable Webmail > URL Rewrite:
-
Click Add Rule(s) button and select Blank rule.
-
Fill in as the following:
-
Add two rules in Conditions section as the following:
-
Check the result:
-
Restart webmail website in IIS > Sites > MailEnable Webmail > Restart.
To enable 80 port for all sites, follow the steps:
-
Log in the server using RDP.
-
Start command prompt as Administrator.
-
Run the following command:
Warning: the command will drop 443 port for all webmails.
C:\> "%plesk_cli%\\repair.exe" --reconfigure-webmail-sites
Comments
3 comments
Unfortunately it did not work. This forces access with HTTPS for all webmails, even for non-HTTPS clients.
It would be nice to have a rule to redirect to HTTPS only if the client installed an SSL certificate in webmail.
@Jefferson André Voigt
Could you please clarify what exactly did not work?
As for a rule to redirect to HTTPS only if the client installed an SSL certificate in webmail, please vote for the feature on Plesk User Voice portal:
https://plesk.uservoice.com/forums/184549-feature-suggestions/suggestions/31900489-redirect-from-http-to-https-for-secured-webmails
Top-ranked suggestions are likely to be implemented in future Plesk releases
Ideally, you should only redirect requests to HTTPS if the client has SSL certificate installed. Voted! Thank you.
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