Google Authenticator declines one-time password that was sent to the mobile phone

Created:

2017-08-04 07:17:51 UTC

Modified:

2017-08-17 14:39:20 UTC

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Google Authenticator declines one-time password that was sent to the mobile phone

Symptoms

Google Authenticator declines one-time password that was sent to the mobile phone:

PLESK_ERROR:is not valid

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Phone number was set correctly and the correct password from the one-time message was entered.

Cause

Incorrect time is set on the server or Google Authenticator is misconfigured

Resolution

Make sure that the correct time is set on the server:

1. Check what is the current time for your time zone:

Capture2.PNG

2. Compare it with the current server time. If it is different, correct it in Plesk > Tools & Settings > System Time or directly on a server:

Capture3.PNG

Otherwise, re-enable Google Authenticator:

  1. Log in to the server over SSH

  2. Disable the extension:

    # plesk bin extension --disable google-authenticator

  3. Login to Plesk and make sure Google Authenticator is configured correctly.

  4. Enable it back:

    # plesk bin extension --enable google-authenticator

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