Unable to update Plesk: Failed to solve dependencies

Created:

2017-01-31 06:09:11 UTC

Modified:

2017-08-08 13:24:30 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to update Plesk: Failed to solve dependencies

Applicable to:

  • Plesk for Linux

Symptoms

Plesk cannot be updated with the following error:

--> Finished Dependency Resolution 
Error: Package: php-5.3.3-48.el6_8.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
Requires: php-cli(x86-64) = 5.3.3-48.el6_8.cloudlinux
Installed: php-cli-5.4.45-56.el6.art.x86_64 (@atomic)
...
Exception: Failed to solve dependencies

Cause

PHP was not installed properly from the Atomic repository.

Resolution

Install necessary PHP packages from the Atomic repository. For example:

# yum install php --enablerepo=atomic --disablerepo=cloudlinux-x86_64-server-6
Have more questions? Submit a request
Please sign in to leave a comment.