This is not possible to manage PHP versions by Plesk admin

Created:

2017-01-30 20:59:40 UTC

Modified:

2017-08-08 13:41:35 UTC

0

Was this article helpful?


Have more questions?

Submit a request

This is not possible to manage PHP versions by Plesk admin

Applicable to:

  • Plesk for Linux

Symptoms

  • This is not possible to manage PHP versions by Plesk admin.

  • Permission manage_php_version is set as false for admin client:

mysql> select p.id,p.permission,p.value,cl.login,cl.permid from Permissions p, clients cl where p.permission="managephp_version";

+----+--------------------+-------+-------+---------+
| id | permission| value | login | perm_id |
+----+--------------------+-------+-------+---------+
| 1 | manage_php_version | false | admin | 1 |
| 2 | manage_php_version | true | admin | 1 |
+----+--------------------+-------+-------+---------+

Cause

Permission manage_php_version is set as false for admin client

Resolution

1. Create backup of Plesk database:

MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysqldump -u admin psa > psa`date +%F_%H.%M`.sql

2. Update permissions for admin user:

mysql> update Permissions set value="true" where permission="manage_php_version" and id=1;
Have more questions? Submit a request
Please sign in to leave a comment.