Cannot install QMail

Created:

2017-07-30 18:15:07 UTC

Modified:

2017-08-16 16:23:57 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot install QMail

Applicable to:

  • Plesk for Linux

Symptoms

Cannot switch from Postfix to QMail with the following error:

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
---X--- `apt-get` output ---------------------
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
plesk-mail-pc-driver : Conflicts: psa-mail-driver
Conflicts: psa-qmail but 3:1.03-debian8.0.build1700161026.19 is to be installed
plesk-mail-qc-driver : Depends: psa-qmail-rblsmtpd but it is not going to be installed
Conflicts: postfix but 2.11.3-1+deb8u2 is to be installed
Conflicts: psa-mail-driver
postfix : Conflicts: mail-transport-agent
psa-qmail : Conflicts: mail-transport-agent
---------------------- `apt-get` output ---X---

Execution of apt-get -f install fails with the error:

Removing postfix-pcre (2.11.3-1+deb8u2) ...
/var/lib/dpkg/info/postfix-pcre.prerm: 18: .: Can't open /usr/share/postfix/postinst.functions
dpkg: error processing package postfix-pcre (--remove):
subprocess installed pre-removal script returned error exit status 2
/var/lib/dpkg/info/postfix-pcre.postinst: 25: .: Can't open /usr/share/postfix/postinst.functions
dpkg: error while cleaning up:
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
postfix-pcre
E: Sub-process /usr/bin/dpkg returned an error code (1)

Cause

Corrupted package postfix-pcre

Resolution

  1. Remove the info about postfix-pcre package from /var/lib/dpkg/status . Create a backup of this file first
  2. Run Plesk installer to complete installation of QMail service.
Have more questions? Submit a request
Please sign in to leave a comment.