Changing IP address for outgoing mail in Mail Server Settings fails with 504 Gateway Time-Out

Created:

2017-01-24 20:49:40 UTC

Modified:

2017-08-08 13:42:56 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Changing IP address for outgoing mail in Mail Server Settings fails with 504 Gateway Time-Out

Applicable to:

  • Plesk for Linux

Symptoms

Changing IP address for outgoing mail server-wide in Tools & Settings > Mail Server Settings fails with error:

504 Gateway Time-Out

Leftover records are present in /etc/postfix/master.cf :

plesk-203.0.113.2- unix - n n - - smtp -o smtp_bind_address=203.0.113.2 -o smtp_bind_address6= -o smtp_address_preference=ipv4
plesk-203.0.113.3- unix - n n - - smtp -o smtp_bind_address=203.0.113.3 -o smtp_bind_address6= -o smtp_address_preference=ipv4
plesk-203.0.113.4- unix - n n - - smtp -o smtp_bind_address=203.0.113.4 -o smtp_bind_address6= -o smtp_address_preference=ipv4
plesk-203.0.113.5- unix - n n - - smtp -o smtp_bind_address=203.0.113.5 -o smtp_bind_address6= -o smtp_address_preference=ipv4

Cause

Task takes some time to complete while the web server does not keep alive the connection long enough.

Resolution

Execute the command from Command-Line Interface:

plesk bin mailserver --set-outgoing-email-mode explicit-ip -explicit-ipv4  203.0.113.2

If the previously mentioned records are still present in /etc/postfix/master.cf , remove or comment them manually.

Restart postfix:

# service postfix restart
Have more questions? Submit a request
Please sign in to leave a comment.