Plesk for Windows
Plesk for Linux
kb: technical
ABT: Group B
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
The following error appears opposite the Application Startup File in Domains > example.com > Node.js:
PLESK_ERROR: The file does not exist
Cause
Application Startup File is missing in the Application Root directory.
Resolution
-
Go to Domains > example.com > Node.js.
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Verify that the Application Root directory is set to the existing directory.
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Make sure that the Application Startup File is set to the existing file located in the Application Root directory.
Additional information:
For the working capacity of Node.js, the following conditions should be met:
-
For Linux:
The Application Root directory must be equal to the subdirectory of the Document Root directory
-
For Windows:
The Application Root directory must be equal to the Document Root directory.
Comments
2 comments
Thank you for this info, but for the life of me I *still* can't find the app.js file. Plesk says it's installed, but I don't see any evidence of node in my domain. The 'file does not exist' notification is still next to the app.js in the Application Startup File row. Thoughts?
Hi Tre Stange,
This message means that there is no such file in the application root.
For example, there is no app.js file in /httpdocs/. However, if you create a file app.js in that same directory /httpdocs/, no error will be shown.
In case applications is using another startup file, for example server.js, you can just click on app.js and specify another startup file name.
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