Cannot access Plesk via HTTPS protocol on port 8443: Secure Connection Failed

Created:

2017-07-26 12:43:42 UTC

Modified:

2017-08-16 17:17:21 UTC

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Cannot access Plesk via HTTPS protocol on port 8443: Secure Connection Failed

Applicable to:

  • Plesk Onyx for Windows

Symptoms

Cannot access Plesk via HTTPS protocol on port 8443. The following error in browser:

Secure Connection Failed

OR

ERR_CONNECTION_RESET

Cause

SSL certificate for Plesk has been installed incorrectly.

Resolution

Here is the steps how to secure Plesk with SSL certificate:

  1. Go to Tools & Settings > SSL/TLS Certificates (in the Security group) and install SSL certificate.
  2. Then click Change near the Certificate for securing Plesk field.
  3. In the opened Secure Plesk dialog, select one of the available certificates and click OK .

Refer the following article for details - Securing Plesk and Mail Server

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