Unable to start migration: Unable to execute command because another migration is in progress

Created:

2017-07-25 00:00:39 UTC

Modified:

2017-08-16 17:03:40 UTC

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Unable to start migration: Unable to execute command because another migration is in progress

Applicable to:

  • Plesk for Windows

Symptoms

Unable to start migration. The following message is shown in Plesk Migrator UI:

Unable to execute command because another migration is in progress

Cause

Possible causes:

  1. Another running migration process running.

  2. Plesk Migrator processes are stuck.
  3. Temporary files left after previous processes. Temporary files can present if the process was crashed or "killed" by a user and thus clean up was not performed properly.

Resolution

  1. Login to Plesk > Tools & Setting > Migration and Transfer Manager .
  2. Stop all running migrations and remove all sessions.
  3. Log in to the server over RDP using the article: How to connect to the server using SSH/RDP .
  4. Remove orphan directories from previous migration sessions:
    4.1. Open File Explorer and navigate to the directory %plesk_dir%var\modules\panel-migrator\sessions 4.2. If there are any directories inside "sessions" directory remove them.
  5. Press "Ctrl" + "Shift" + "Esc" to open Task Manager.
  6. In Task manager Find and finish the following processes:
    • python.exe,
    • rsync.exe
    • paexec.exe
    • MailMigrator.exe
    • pmmcli.exe
  7. Open Plesk > Tools & Setting > Migration and Transfer Manager and start a new mitigation.
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