How to enable imagick support in CMS or website in Plesk?

Follow

Comments

7 comments

  • Avatar
    Vladimir Chernikov

    Hello @Daryl Phillips,

    >> What is the progress with this? 

    The GD library shipped with Plesk PHP 7.2 and higher supports WebP starting from Plesk Obsidian 18.0.27:
    https://support.plesk.com/hc/en-us/articles/360012609933-WebP-support-in-PHP-packages-provided-by-Plesk

    In case you mean ImageMagick system package, you could manually recompile it as described in the following thread:
    https://talk.plesk.com/threads/imagemagick-6-7-8-with-webp-libwebp-support-on-centos-7-7-1908.354031/ 

    As such scenario is not officially supported all actions to be done at your own risk.

    >> Will we ever see the ability to have WEBP enabled, or the ability to have it configured the way we need?

    I've checked Plesk internal sources and there are no plans for implementation from the Plesk side as it depends on OS vendor.

    I appreciate your understanding.

    0
    Comment actions Permalink
  • Avatar
    Daryl Phillips

    What is the progress with this? Will we ever see the ability to have WEBP enabled, or the ability to have it configured the way we need?

    Appreciate that this is more aimed at the OS Vendor, but would be good to find out what the plans are.

    0
    Comment actions Permalink
  • Avatar
    Candlewick Press

    The PHP-Imagick module seems to be install by the provided Plesk php versions, but Wordpress PDF thumbnail generation (which uses Imagick) doesn't work. Is there a way to get this to work properly?

    0
    Comment actions Permalink
  • Avatar
    Karl May

    I use CentOS Linux 7.8.2003 with Plesk Obsidian Version 18.0.27 Update #1

    phpinfo() said:

    imagick module version 3.4.3
    ImageMagick release date 2020-04-01

    In "ImageMagick supported formats" format WEBP is still missing.

    WEBP is supported in GD library https://support.plesk.com/hc/en-us/articles/360012609933 but not in ImageMagick. How do I get WEBP in ImageMagick?

    0
    Comment actions Permalink
  • Avatar
    Konstantin Annikov (Edited )

    Hello, 

    The issue with plugin is being discussed on WordPress support forum: 
    https://wordpress.org/support/topic/bropken-pdf-thumbnail-generation/

    So, please test your installation using `PDF thumbnails support test` plugin and in case everything is ok, please contact plugin's developers. 

    Plesk only provides module for PHP and I could confirm that the module is working on test installation: 

    # cat imagicktest.php
    <?php
    //This function prints a text array as an html list.
    function alist ($array) {
    $alist = "<ul>";
    for ($i = 0; $i < sizeof($array); $i++) {
    $alist .= "<li>$array[$i]";
    }
    $alist .= "</ul>";
    return $alist;
    }
    //Try to get ImageMagick "convert" program version number.
    exec("convert -version", $out, $rcode);
    //Print the return code: 0 if OK, nonzero if error.
    echo "Version return code is $rcode <br>";
    //Print the output of "convert -version"
    echo alist($out);
    ?>

    # /opt/plesk/php/7.1/bin/php imagicktest.php
    Version return code is 0 <br><ul><li>Version: ImageMagick 6.7.8-9 2019-02-01 Q16 http://www.imagemagick.org<li>Copyright: Copyright (C) 1999-2012 ImageMagick Studio LLC<li>Features: OpenMP<li></ul>

    So, I suppose that the issue is on plugin's side.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Karl May

    This may be done manually only.

    For example, check this forum topic

    Also, recently we had a feature suggestion about it. It was rejected because ImageMagick package is provided with OS vendor and does not have support for webp enabled by default.

    0
    Comment actions Permalink
  • Avatar
    ianscott

    I am seeing a problem here, but it seems it has to do with PHP 7.3.17 and PNG support with ImageMagick.

    My client has a PDF plugin for Woocommerce. His logo is in a PNG format. After upgrading his website to PHP 7.3.17, it resulted in errors:


    Exception: NoDecodeDelegateForThisImageFormat

    Reverting back to PHP 7.2 in the Plesk Control panel, the error disappeared. 

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request