Unable to install MSSQL 2008 server: The installation of the package 'sql2008_express' failed with code -2068774911.

Created:

2017-01-18 10:41:29 UTC

Modified:

2017-08-08 13:41:16 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install MSSQL 2008 server: The installation of the package 'sql2008_express' failed with code -2068774911.

Applicable to:

  • Plesk 12.0 for Windows

Symptoms

Unable to install MSSQL 2008 R2 server. Installation with Plesk installer fails with the following error:

Unable to install exe package 'C:\ParallelsInstaller\parallels\PANEL-WIN_12.0.18\thirdparty-msi-Windows-any-x86_64\sql2008r2sp2express-x64.exe' with error -2068774911(0x84b10001). 
Output: Error: The installation of the package 'sql2008_express' failed with code -2068774911. (install: installing MSSQL 2008 server...)

The following error can be found in C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\ directory:

Slp: Microsoft.SqlServer.Setup.Chainer.Workflow.ActionExecutionException: There is an error in XML document (1, 2). ---> Microsoft.SqlServer.Chainer.Infrastructure.ChainerInfrastructureException: 
There is an error in XML document (1, 2). ---> System.InvalidOperationException: There is an error in XML document (1, 2). ---> System.TypeInitializationException:
The type initializer for '<Module>' threw an exception. ---> <CrtImplementationDetails>.ModuleLoadException: The C++ module failed to load.
Slp:  ---> System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Cause

.Net 4.5 corruption

Resolution

1. Remove .Net 4.5 feature from the server.
2. Reboot.
3. Install .Net 4.5 feature
4. Try to install MSSQL 2008 R2 again.

Have more questions? Submit a request
Please sign in to leave a comment.