Unable to access to server: Connection Refused

Created:

2017-07-14 04:13:39 UTC

Modified:

2017-08-16 16:26:58 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to access to server: Connection Refused

Applicable to:

  • Plesk for Linux

Applicable to

  • Plesk for Linux

Symptoms

  • Server users are unable to access Plesk web interface.
  • CSF and/or LFD services are running:
    # service lfd status
    Status of lfd:lfd (pid 20834) is running...

Cause

CSF/LFD services are running, blocking access to the server.

Resolution

Add Plesk ports 8443, 8880 to TCP_IN, TCP_OUT directives:

# cat /etc/csf/csf.conf | grep TCP_ | grep -v "^#"
TCP_IN =
"20,21,22,25,53,80,110,143,443,465,587,993,995,8443,8880"
TCP_OUT =
"20,21,22,25,53,80,110,113,443,587,993,995,8443,8880"

Restart csf service:

# csf -r
Note that "ConfigServer Security & Firewall" application is not officially supported by Plesk. It is possible to use iptables + fail2ban feature instead.
Have more questions? Submit a request
Please sign in to leave a comment.