Unable to install MSSQL 2014 from Plesk installer: The installation of the package 'sql2014_express' failed with code -2068052310

Created:

2017-01-07 02:12:23 UTC

Modified:

2017-08-08 13:45:11 UTC

2

Was this article helpful?


Have more questions?

Submit a request

Unable to install MSSQL 2014 from Plesk installer: The installation of the package 'sql2014_express' failed with code -2068052310

Applicable to:

  • Plesk 12.5 for Windows

Symptoms

MSSQL 2014 installation failed with the following error:

The installation of the package 'sql2014_express' failed with code -2068052310 

Checking C:\Program Files\Microsoft SQL Server\120\Setup Bootstrap\Log\Summary.txt it is possible to find the similar error:

 Feature:                       SQL Client Connectivity SDK
  Status:                        Failed: see logs for details
Reason for failure: An error occurred during the setup process of the feature.
Next Step: Use the following information to resolve the error, and then try the setup process again.
Component name: SQL Server Native Client Access Component
Component error code: 1706
Component log file: C:\Program Files\Microsoft SQL Server\120\Setup Bootstrap\Log\20170106_235109\sqlncli_Cpu64_1.log
Error description: An installation package for the product Microsoft SQL Server 2012 Native Client cannot be found. Try the installation again using a valid copy of the installation package 'sqlncli(1).msi'.
Error help link: http://go.microsoft.com/fwlink?LinkId=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=12.0.4100.1&EvtType=sqlncli.msi%40InstallFiles%401706

Cause

Previous version of this package is installed and can not be updated.

Resolution

Download this package manually from Microsoft website and install.

Retry MSSQL 2014 installation from Plesk autoinstaller.

Have more questions? Submit a request

7 Comments

  • 0
    Avatar
    Xusniddin Umarov

    [Errno 256] No more mirrors to try.']. Trying again.
    processTransaction event: 10 (Downloading Packages)
    processTransaction event: 11 (unknown)
    Error while preparing to install packages: [u'Errors were encountered while downloading packages.', u'plesk-php70-ioncube-loader-6.0.7-centos7.16121313.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php71-imagick-3.4.3-centos7.16120617.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php70-redis-3.1.1-centos7.17021618.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php70-xdebug-2.5.0-centos7.17021618.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php71-redis-3.0.0-centos7.16120617.x86_64: [Errno 256] No more mirrors to try.']. Trying again.
    processTransaction event: 10 (Downloading Packages)
    processTransaction event: 11 (unknown)
    Number of retries is exceeded.
    Traceback (most recent call last):
    File "/usr/local/psa/bin/yum_install", line 239, in <module>
    main()
    File "/usr/local/psa/bin/yum_install", line 234, in main
    installer.perform(to_install, opts.remove, opts.tries)
    File "/usr/local/psa/bin/yum_install", line 173, in perform
    self._perform(to_install, to_remove, pt_callback)
    File "/usr/local/psa/bin/yum_install", line 192, in _perform
    self.processTransaction(callback = pt_callback, rpmDisplay = QuietCallback())
    File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6533, in processTransaction
    pkgs = self._downloadPackages(callback)
    File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6568, in _downloadPackages
    raise Errors.YumDownloadError, errstr
    YumDownloadError: [u'Errors were encountered while downloading packages.', u'plesk-php70-ioncube-loader-6.0.7-centos7.16121313.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php71-imagick-3.4.3-centos7.16120617.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php70-redis-3.1.1-centos7.17021618.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php70-xdebug-2.5.0-centos7.17021618.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php71-redis-3.0.0-centos7.16120617.x86_64: [Errno 256] No more mirrors to try.']
    sh: /etc/init.d/psa: No such file or directory
    Bootstrapper has finished action (exec time: 0 sec.): parent_name='PLESK_17_5_3', sequence='pkgs', stage='rollback', sequence_order='1', operation='install', exec_cmd='rm -f /tmp/pp-bootstrapper-mode.flag; rm -f /var/lock/parallels-panel-maintenance-mode.flag; touch /var/lock/parallels-panel-upgrade-failure.flag; /etc/init.d/psa restart; :'', m_arch='', output: ~empty
    [2017-03-28 12:45:54.431393] Execute command /usr/local/psa/admin/bin/send-error-report install --version 17.5.3
    [2017-03-28 12:45:54.433490] Warning: Failed to attach to cgroup /sys/fs/cgroup/systemd/user/root/tasks, installer might be unexpectedly killed later by the system
    [2017-03-28 12:45:54.455460] Error: Не удалось запустить утилиту Yum.
    Утилита Yum не смогла установить требуемые пакеты.
    Внимание! Ваше программное обеспечение может быть нерабочим.
    Пожалуйста, обратитесь в службу технической поддержки по продукту.

  • 0
    Avatar
    Xusniddin Umarov

    parallels-installation-log

  • 0
    Avatar
    Artyom Baranov

    Здравствуйте!

    Данная статья не применима к описанной Вами ошибке. Попробуйте применить эту статью: https://support.plesk.com/hc/en-us/articles/115002110049

    Надеюсь, проблема будет решена!

  • 0
    Avatar
    Xusniddin Umarov

    Здравствуйте,

    Не получается исправит ошибку.

     

  • 0
    Avatar
    Lev Iurev

    попробуйте после применения статьи запустить yum clean cache

  • 0
    Avatar
    Xusniddin Umarov

    не получается установит вот ошибка


    plesk-php70-ioncube-loader-6.0.7-centos7.16121313.x86_64 | 411 kB 00:02
    http://autoinstall.plesk.com/PHP70_17/dist-rpm-CentOS-7-x86_64/packages/plesk-php70-ioncube-loader-6.0.7-centos7.16121313.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=PLESK_17_PHP70 clean metadata
    Trying other mirror.
    Number of retries is exceeded.
    YumDownloadError: [u'Errors were encountered while downloading packages.', u'plesk-php70-ioncube-loader-6.0.7-centos7.16121313.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php71-redis-3.0.0-centos7.16120617.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php71-imagick-3.4.3-centos7.16120617.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php70-redis-3.1.1-centos7.17021618.x86_64: [Errno 256] No more mirrors to try.', u'plesk-php70-xdebug-2.5.0-centos7.17021618.x86_64: [Errno 256] No more mirrors to try.']
    sh: /etc/init.d/psa: No such file or directory

    ERROR: Failed to run the Yum utility.
    The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please contact product technical support.

     

  • 0
    Avatar
    Artyom Baranov

    Здравствуйте,

    Выполните, пожалуйста, следующую команду в терминале Вашего сервера и напишите её вывод здесь.

    cat /etc/yum.repos.d/CentOS-Base.repo

Please sign in to leave a comment.