Is it possible to use Let's Encrypt for wildcard certificates?

Follow

Comments

15 comments

  • Avatar
    Chris Eyre

    Let's Encrypt have announced a delay - See https://community.letsencrypt.org/t/acmev2-and-wildcard-launch-delay/53654

    Does the current Let's Encrypt Plesk extension version already include the ability to automatically provide wildcard certificates as soon as Let's Encrypt start to offer them?    Or will there be a new version that I'll need to download sometime in the future?

    Thanks

  • Avatar
    Alexandr Tumanov

    @Chris,

    It may be required to update Let's Encrypt extension to get the support for this feature in future.

  • Avatar
    Chris Eyre

    Hi,

    Thank you for your answers so far.

    I see from the article linked below, that Let's Encrypt wildcard support is now live!

    https://community.letsencrypt.org/t/acme-v2-and-wildcard-certificate-support-is-live/55579

    Are there any plans and timetable for wildcard support to be added to the Plesk Let's Encrypt extension?

    Thank you,

    Chris

  • Avatar
    Alexandr Tumanov

    @Chris,

    Yes, we have plans to add the support of wildcards certificates. However, as for now, Plesk Let's Encrypt extension has few limitations that do not allow it to support wildcard certificates. Currently, we cannot provide any ETA.

  • Avatar
    Arnaud

    what is the Plesk priority in roadmap on this ?

  • Avatar
    Alexandr Tumanov

    @Arnaud, currently, it is planned to release the update within one month. However, the release date may be changed.

  • Avatar
    Arnaud

    Great news ! Thanks for having taken this into account in short term roadmap !

    - Arnaud

  • Avatar
    Mark

    Is there an update on this?

  • Avatar
    Alexandr Tumanov

    @Mark, as it previously stated, it is planned within one month. There is no exact date. Just keep an eye on Plesk extension updates.

  • Avatar
    Hisham

    @Alexandr,

    for which Plesk versions will the wildcard support be available. ONYX 17.017, 17.5.3 or higher?
    I'm currently running 17.0.17 and would need to know whether I need to have to upgrade to higher version, so I can prepare upfront.

    Thanks in advance

  • Avatar
    Alexandr Tumanov

    @Hisham, the update will be for Let's Encrypt extension that should be compatible with all Onyx versions, but I cannot guarantee this.

    Therefore, I suggest you upgrading your server up to 17.8

  • Avatar
    Jeffrey Tanuwidjaja

    Is there an update on this?

     
  • Avatar
    Ivan Postnikov

    Hello @Jeffrey! This feature implementation is currently in progress. 

    After it will be implemented, the article will be updated.

  • Avatar
    Julius Huitema

    Hi,

    I know that this feature implementation is currently in progress but could you give me an indication of when this will be usable? Like a couple of days, weeks, months or even years?

    Thank you very much!
    Julius

  • Avatar
    Artyom Baranov

    @Julius Huitema,

    Hello! Unfortunately, we don't have such information :( The implementation of the feature requires a careful testing. It is hard to say for sure how much time it will take.

    I suggest to "Follow" this article to be notified as soon as the new information is available.

Please sign in to leave a comment.

Have more questions? Submit a request