Applicable to:
- Plesk for Linux
Symptoms
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A website has been migrated to Plesk from a legacy Plesk version.
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When opening this website in a web-browser, it loads the real content over HTTP, but different over HTTPS. For HTTPS, it also can be a Plesk default page or Apache test page.
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Opening other pages of the website over HTTPS result in "404 Not Found" or "403 Forbidden".
Cause
The domain is running in "Separate SSL/TLS and non-SSL/TLS content" compatibility mode which is enabled at Domains > example.com > Hosting Settings.
Domains in Plesk 11 and earlier releases had their content stored in separate directories for HTTP and HTTPS:
/var/www/vhosts/example.com/httpdocs
- for HTTP content/var/www/vhosts/example.com/httpsdocs
- for HTTPS content
Resolution
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Go to Domains > example.com > Hosting Settings.
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Uncheck the option
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Apply the changes.
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Connect to the Plesk server via SSH.
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Disable the compatibility mode in the Plesk database:
# plesk db "UPDATE hosting set same_ssl='true' WHERE same_ssl='false';"
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Repair web-server configuration:
# plesk repair web -y
Comments
3 comments
einige Male ist dies hilfreich:
mail: /var/www/vhosts/mydomain.com/httpdocs# zu finden. -Typs d -exec chmod 755 {} \;
mail: / var / www / vhosts / mydomain.com/httpdocs# zu finden. -type f -exec chmod 644 {} \;
Hello @Jan,
Thank you for sharing your experience.
Error 403 indeed may have a variety of causes, the commands you used set the permissions on files this is a solution in case permissions are incorrect.
I am getting forbidden issue
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Check screenshot: https://prnt.sc/11pdcst
Not able to resolve it.
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