Cannot install a Let's Encrypt certificate on a subdomain with mixed letters: too many certificates already issued for exact set

Created:

2017-06-26 12:57:35 UTC

Modified:

2017-08-16 17:25:30 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot install a Let's Encrypt certificate on a subdomain with mixed letters: too many certificates already issued for exact set

Applicable to:

  • Plesk Onyx for Windows

Note: This article has the reference to the issue with the fix available:

  • #EXTLETSENC-198 "A failed certificate installation led to exhausting the Let’s Encrypt rate limits for a domain, which resulted in inability to renew the certificate."
    Fixed in:
Please consider updating your server:

Symptoms

Creation of subdomains with mixed letters leads to auto-renew of the cert repeatedly and cause the error:

Error Creating new cert :: too many certificates already issued for exact set 

Cause

Failed certificate installation to Plesk exhausts LE's domain rate limits. This is Let's Encrypt extension bug with ID EXTLETSENC-198 that will be fixed in future updates.

Resolution

As a workaround, download and unpack a temporary fix .

The certificate renewal can be enforced using the following command:

# plesk bin extension --exec letsencrypt renew.php SubDomain.example.com

Attachments:

Have more questions? Submit a request
Please sign in to leave a comment.