Unable to open httpdocs folder through File Manager: Access denied

Created:

2016-12-30 12:41:37 UTC

Modified:

2017-08-10 15:09:14 UTC

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Unable to open httpdocs folder through File Manager: Access denied

Applicable to:

  • Plesk Onyx for Windows

Note: This article has the reference to the issue with the fix available:

  • #PPPM-5501 "After upgrading to Plesk Onyx, websites could become inoperable if custom permissions for the inetpub\vhosts folder were configured in the %plesk_dir%\etc\disksecurity\custom.xml file."
    Fixed in:
Please consider updating your server:

Symptoms

  • Error when opening Plesk > Domains > example.com > File Manager:
    Unable to open the directory: Unable to find the directory C:\Inetpub\vhosts\example.com\httpdocs: Access denied
  • "Denied" privileges are set for psacln user on the httpdocs directory of the domain.
  • Custom DiskSecurity file persist in the %plesk_dir%/etc/DiscSecurity folder. The file grants FullAccess permissions to custom user. For example, the file contains the following:
    <?xml version="1.0" encoding="utf-8" ?> 
    <Entries>
    <Entry AccounType="1" Account="example" Path="C:\InetPub\vhosts" AceFlags="ThisFolderSubfoldersAndFiles" AccessMask="FullAccess" />
    </Entries>

Cause

This is bug with ID PPPM-5501 which is planned to be fixed in future Plesk updates.

Resolution

As a workaround set EntryFlags to 0x10 (which adds the No Propagate option for the rule). The example of such a rule:

<?xml version="1.0" encoding="utf-8" ?> 
<Entries>
<Entry AccounType="1" Account="example" Path="C:\InetPub\vhosts" AceFlags="ThisFolderSubfoldersAndFiles" AccessMask="FullAccess" EntryFlags="0x10" />
</Entries>

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