Unable to login to FTP: 530 User cannot log in, home directory inaccessible

Created:

2017-06-16 22:22:14 UTC

Modified:

2017-08-16 17:15:09 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to login to FTP: 530 User cannot log in, home directory inaccessible

Applicable to:

  • Plesk for Windows

Symptoms

1. Plesk server is behind NAT.

2. Trying to connect to the server via public IP address via FTP fails:

530 User cannot log in, home directory inaccessible

3. On attempt to access Subscriptions > example.com > File Sharing the following error appears:

Filesharing: Internal error: Error in cURL request: Recv failure: Connection was reset
Unable to load folders list.

4. There are at least 2 IP addresses configured at Plesk > Tools & Settings > IP Addresses . One of them is configured with a public IP address and does not exist on the server network interface. example.com is assigned to this IP address. Another IP address does exist on the server.

Cause

Improper network interface configuration. Public IP address is configured for non-existent private IP.

Resolution

Review network configuration and make sure that public IP address is assigned to an existent private IP address. Assign all domains to the existent IP address.

Have more questions? Submit a request
Please sign in to leave a comment.