Plesk inaccessible: Dependent row(s) 'smb_roles.id = 1' isn't found for 'smb_users.roleId = 1'

Follow

Comments

10 comments

  • Avatar
    Marcin Luniz

    luniz@localhost:~$ sudo plesk db
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A

    Welcome to the MariaDB monitor. Commands end with ; or \g.
    Your MariaDB connection id is 566
    Server version: 10.1.29-MariaDB-6 Ubuntu 18.04

    Copyright (c) 2000, 2017, Oracle, MariaDB Corporation Ab and others.

    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

    MariaDB [psa]> INSERT INTO smb_roles VALUES (1,'Admin',1,1),(2,'WebMaster',0,1),(3,'Application User',0,1),(4,'Accountant',1,1);
    ERROR 1136 (21S01): Column count doesn't match value count at row 1
    MariaDB [psa]>

  • Avatar
    Marcin Luniz

    ok. Sorry. THX 

     

    that works, 

    mysql> INSERT INTO smb_roles VALUES (1,'Admin',1,1,0),(2,'WebMaster',0,1,0),(3,'Application User',0,1,0),(4,'Accountant',1,1,0);
    mysql> UPDATE smb_users SET ownerId=1;

  • Avatar
    Anzhelika Khapaknysh

    Hi @Marcin Luniz!

    Glad to know the issue is fixed!
    The article was updated a bit to be more clear.

  • Avatar
    Phobos A. D'thorga

    Thank you so much! This fixed my issues right up with Plesk Onyx on a clean install of CentOS 7.

  • Avatar
    Alisa Kasyanova

    @Phobos A. D'thorga

    Glad to know that it helped!

    You may subscribe to this article to be notified when the bug would be fixed, so there would be no need to execute these steps on other Plesk servers.

  • Avatar
    Phobos A. D'thorga

    @Alisa Kasyanova 

    Already ahead of you! :) I should mention too that you can't login to this website with Chrome unless perhaps you have to enable third-party cookies? How do I go about reporting that, if it's even reportable?

  • Avatar
    Alisa Kasyanova

    @Phobos A. D'thorga

    It is an expected behaviour of our site. And if cookies are not enabled, there should be a "Cookies must be enabled in your browser to sign in" warning.

  • Avatar
    Mikhail Krivoshein

    Just encountered the same problem when installing the latest Plesk Onyx on a brand new Centos server 3 times (3  new servers). After I followed the instructions and also added SELinux Policy component, things appear to be back to what I could expect. Looks like SELinux Policy shall be a mandatory component if its absence breaks the installation process.

  • Avatar
    Sysadmin (Edited )

    I'm getting this error on every new install on Virtuozzo 7 VMs.

    This is my install command: wget https://autoinstall.plesk.com/plesk-installer -O - | sh /dev/stdin install plesk --target /tmp/plesk-installation --components advisor bind cloudflare config-troubleshooter dovecot fail2ban health-monitor git letsencrypt modsecurity nginx panel php7.3 postfix proftpd psa-firewall roundcube social-login spamassassin webalizer webservers

  • Avatar
    Alisa Kasyanova

    @Sysadmin
    I have reproduced the issue on my test VZ7 VM with the provided command.
    I have also found the resolution: add the "selinux" component at the end of the command, e.g:

    wget https://autoinstall.plesk.com/plesk-installer -O - | sh /dev/stdin install plesk --target /tmp/plesk-installation --components advisor bind cloudflare config-troubleshooter dovecot fail2ban health-monitor git letsencrypt modsecurity nginx panel php7.3 postfix proftpd psa-firewall roundcube social-login spamassassin webalizer webservers selinux

    Hope this helps!

Please sign in to leave a comment.

Have more questions? Submit a request