Plesk is slow: Token validation failed: The license key was not verified

Created:

2017-06-06 09:01:21 UTC

Modified:

2017-08-16 17:11:39 UTC

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Plesk is slow: Token validation failed: The license key was not verified

Applicable to:

  • Plesk for Linux

Symptoms

Plesk is slow, however, there are enough system resources on the server.

  • The following errors appear in /var/log/plesk/panel.log :

    ERR [1] Exception: Token validation failed: The license key 'PLSK.0000000' was not verified. Plesk will try to verify license key. Please wait for few minutes and try again. To manually run verification of license key click "Retrieve Keys" button in "License Management". 
    file: /usr/local/psa/admin/plib/functions.php
    line: 2232
    code: 0
    trace: #0 /usr/local/psa/admin/plib/functions.php(2078): KeyLimitsChecker::checkKeyToken(boolean false)
    #1 /usr/local/psa/admin/plib/functions.php(2127): KeyLimitsChecker::checkKeyLight(boolean false)
    #2 /usr/local/psa/admin/plib/functions.php(2383): KeyLimitsChecker::checkKey(boolean false)
    #3 /usr/local/psa/admin/plib/auth.php(453): KeyLimitsChecker::resetKeyLocks()
    #4 /usr/local/psa/admin/plib/auth.php(235): AutoPrepend->initUserSession()
    #5 /usr/local/psa/admin/plib/auth.php(717): AutoPrepend->run()
  • Pressing Retrieve Keys at Plesk > Tools & Settings > Licence Management shows that the license is up-to-date.

  • The /etc/sw/keys/instances directory has permissions that differ from an example below:

    # ls -la /etc/sw/keys/ | grep instances
    drwxrws--- 2 root swkey-data 4096 Jun 2 2012 instances

Cause

Plesk keys registry file is corrupted.

Resolution

  1. Change permissions on the /etc/sw/keys/instances directory to the correct:

    # ls -la /etc/sw/keys/ | grep instances
    drwxrws--- 2 root swkey-data 4096 Jun 2 2012 instances
  2. Go to Plesk > Tools & Settings > Licence Management and press Retrieve Keys .

If the issue still persists, perform the following actions:

  1. Backup the file /etc/sw/keys/registry.xml :

    # mv /etc/sw/keys/registry.xml /etc/sw/keys/registry.xml.bak
  2. Regenerate the file by pressing Retrieve Keys at Plesk > Tools & Settings > Licence Management .

  3. If it did not help, reinstall the license key at Plesk > Tools & Settings > Licence Management > Install Key .

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