Information on some packages might not be actual: inconsistencies were detected in the system's package manager database

Created:

2016-12-23 00:18:50 UTC

Modified:

2017-08-08 13:18:58 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Information on some packages might not be actual: inconsistencies were detected in the system's package manager database

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Error message in Tools & Settings > System Updates :

Warning: Information on some packages might not be actual: inconsistencies were detected in the system's package manager database. Please resolve this issue manually.

There are the following packages available for update in Tools and Settings > System Updates :

openssh-server-5.3p1-84.1.el6.x86_64
openssh-clients-5.3p1-84.1.el6.x86_64

Clicking on Update does not have any affect: both packages are still marked as available for update.

Trying to check for updates manually fails:

# plesk sbin pum --check
INFO: pum is called with arguments: ['--check']
Loaded plugins: fastestmirror, security
Error: check ['dependencies', 'duplicates', 'obsoletes']
openssh-clients-5.3p1-84.1.el6.x86_64 has missing requires of openssh = ('0', '5.3p1', '84.1.el6')
openssh-server-5.3p1-84.1.el6.x86_64 has missing requires of openssh = ('0', '5.3p1', '84.1.el6')
2016-12-26 18:49:59 ERROR: Exited with returncode 1.
exit status 1

The same error is found in /var/log/plesk/panel.log with util_exec debug mode enabled.

Trying to install openssh-server or openssh-clients manually fails with the following error:

# yum update openssh-clients
***
No Packages marked for Update

There is an exclusion in /etc/yum.conf file:

exclude=openssh*

Cause

Plesk System Updates tool identified that there is an update available for openssh-server and openssh-clients, but it could not update it because yum tool excluded all updates for openssh* packages

Resolution

Remove an exclusion from /etc/yum.conf file by commenting the following line:

#exclude=openssh*

Additional information

If this does not help, visit the following article:

Warning: Information on some packages might not be actual: inconsistencies were detected in the system's package manager database. Plesk resolve this issue manually

Have more questions? Submit a request
Please sign in to leave a comment.