When protocol https is not specified, Plesk on port 8443 is not opening

Created:

2017-06-02 15:59:46 UTC

Modified:

2017-08-10 15:09:55 UTC

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When protocol https is not specified, Plesk on port 8443 is not opening

Applicable to:

  • Plesk Onyx 17.5

Note: This article has the reference to the issue with the fix available:

  • #PPPM-6366 "Opening Plesk Panel by URL with port 8443 and no protocol specified resulted in returning an HTTP response code 400 instead of redirecting to HTTPS."
    Fixed in:
Please consider updating your server:

Symptopms

When opening Plesk on port 8443 without the protocol https specified - <example.com:8443> or <203.0.113.2:8443>, Plesk is not opening showing a blank page or:

400 Bad Request

Cause

Plesk bug with ID #PPPM-6366 .

The fix will be included in one of the future Plesk updates.

Answer

As a workaround, perform the following steps:

1. Open the file /etc/sw-cp-server/conf.d/plesk.inc in an editor and add the following line in the Custom error pages section:

error_page 497 https://$hostname:$server_port$request_uri;

So it will look like:

# Custom error pages
error_page 497 https://$hostname:$server_port$request_uri;
error_page 400 401 403 404 405 406 407 412 414 415 500 501 502 503 @err;


                location @err {
                        try_files /error_docs/$status.html /error_docs/404.html;
                        internal;
                }


2. Restart the sw-cp-server service:

# service sw-cp-server restart
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