Let's Encrypt certificate is not renewed in IIS configuration

Created:

2017-06-01 07:11:41 UTC

Modified:

2017-08-16 17:29:19 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Let's Encrypt certificate is not renewed in IIS configuration

Applicable to:

  • Plesk for Windows

Symptoms

Let's encrypt certificate for WebMail cannot be updated on Windows. Neither automatically by "Let's Encrypt Extension" task, nor manually under Plesk > Domains > example.com > Let's Encrypt > Renew . No errors appear but in IIS domain old SSL certificate is shown.

Cause

IIS does not use certificates updated via XML-RPC. This is Plesk bug with ID PPPM-5890 which will be fixed in future Plesk updates.

Resolution

As a workaround:

1. Unassign an SSL certificate from WebMail in Domains > example.com > SSL/TLS Certificate .

2. Remove this certificate from Domains > example.com > SSL/TLS Certificate .

3. Assign new certificate from Domains > example.com > Let's Encrypt .

Have more questions? Submit a request
Please sign in to leave a comment.