Virtuozzo ReadyKernel failed to check or update kernel patch: Error: Kernel is not supported for your OS distribution

Created:

2017-06-01 03:53:23 UTC

Modified:

2017-08-16 16:11:01 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Virtuozzo ReadyKernel failed to check or update kernel patch: Error: Kernel is not supported for your OS distribution

Applicable to:

  • Plesk Onyx for Linux

Symptoms

When opening the extension Virtuozzo ReadyKernel, the following error is shown:


Error: Virtuozzo ReadyKernel failed to check or update kernel patch:
Execution readykernel_wrapper has failed with exit code 1, stdout: Checking for patch updates for kernel 3.10.0-514.21.1.e17.x86_64...

Checking for patch updates for kernel 3.10.0-514.e17.x86_64...
Running depmod...
Done.
Installing /lib/modules/3.10.0-514.e17.x86_64/extra/readykernel-patch/kpatch-cumulative-10-0-rl.ko (3.10.0-514.e17.x86_64)
Created symlink from /etc/systemd/system/multi-user.target.wants/kpatch.service to /usr/lib/systemd/system/kpatch.service.

Checking for patch updates for kernel rlsoft...

, stderr: Error: Kernel 3.10.0-514.21.1.e17.x86_64 is not supported for your OS distribution. For details, check https://readykernel.com Error: Kernel rlsoft is not supported for your 05 distribution. For details, check https://readykernel.com

Cause

Unsupported kernel version is installed on the server. ReadyKernel repository does not contain a patch for the kernel used on the server.

Resolution

Install and load the supported kernel version.

OR

Wait until a patch for the currently used version is released.

Have more questions? Submit a request
Please sign in to leave a comment.