Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
A website behind Cloudflare shows the following error message in a web-browser:
PLESK_INFO: ERR_TOO_MANY_REDIRECTS
OR
PLESK_INFO: The page isn’t redirecting properly
-
When Cloudflare is disabled, the website loads fine.
-
The Permanent SEO-safe 301 redirect from HTTP to HTTPS setting is enabled in Plesk at Domains > example.com > Hosting Settings or custom HTTPS redirection is configured in domain's .htaccess file.
Cause
The SSL setting is set as "Flexible" in Cloudflare Crypto settings for this domain.
Resolution
Log in to your Cloudflare account > click on the domain > click Crypto and change the SSL setting to "Full (strict)".
Note: The CloudFlare account is created automatically during the initial activation of the extension. Since the CloudFlare extension is enabled on the server, the corresponding account on a CloudFlare side already exists. If the account credentials are forgotten, try to recover the password via the following link to access Cloudflare dashboard: https://www.cloudflare.com/a/forgot-password
The same email should be specified as for the initial extension setup.
Comments
4 comments
This has been stumping me for a while, but setting all of our sites in cloudflare to Full (strict) solved our issue!
Hi @Blake!
Thank you for the feedback. Good to hear that the solution helped.
This does not work for me, I end with a
Error 526
Invalid SSL certificate
Do you have any idea what i'm doing wrong ?
@Martin, this error could be caused by different things. I recommend opening a support ticket with us https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
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