Applicable to:
- Plesk Onyx for Linux
Symptoms
-
Cannot receive emails. The following error may be found in
/var/log/maillog
:CONFIG_TEXT: postfix/smtpd[5105]: NOQUEUE: reject: RCPT from unknown[203.0.113.2]: 450 4.7.1 <203.0.113.2>: Client host rejected: Service unavailable; from=<john.doe@example1.com> to=<jane.doe@example2.com> proto=ESMTP helo=<[203.0.113.2]>
-
Warnings in
/var/log/maillog
:CONFIG_TEXT: postfix/smtpd[5105]: warning: 192.0.2.2.dnsbl.example.com: RBL lookup error: Host or domain name not found. Name service error for name=192.0.2.2.dnsbl.example.com type=A: Host not found, try again
-
The Postfix configuration parameter smtpd_recipient_restrictions is configured to use DNSBL service dnsbl.example.tld in
/etc/postfix/main.cf
file:# grep dnsbl.example.com /etc/postfix/main.cf smtpd_recipient_restrictions = ...permit_dnsbl_client dnsbl.example.com=192.0.2.2,
Cause
Plesk is configured to use non-existent DNSBL service.
Resolution
Remove non-existent DNSBL in Plesk > Tools & Settings > Mail Settings:
Also, it can be done using command line:
- Log in to Plesk using SSH.
-
Remove non-existent DNSBL service dnsbl.example.com from Postfix configuration in
/etc/postfix/main.cf
:CONFIG_TEXT: # permit_dnsbl_client list.dnsbl.example.com=192.0.2.2
-
Restart Postfix:
# service postfix restart
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